Hur uppdaterar jag mitt Composerdokument med en SOLIDWORKS-fil på bästa sätt?

Förslag på arbetssätt för att förenkla uppdateringsprocessen

1. Exportera en .smg direkt från SOLIDWORKS alternativt ta in filen i Composer och konvertera till .smg. Använd denna fil som ”kontrolldokument” (Version 1).

Inställningar för exportprofil i SOLIDWORKS finns under System Options> Export. I de flesta fall rekommenderas export/import- profilen SOLIDWORKS (Default). För att få med ytor in i Composerfilen används SOLIDWORKS with surface parts.

2. Med .smg:n öppen i Composer, spara direkt ut en ”arbetsfil” med nytt namn. Det är i denna fil ni jobbar med Composerdokumentet.

3. När sedan ursprungsfilen i SOLIDWORKS ändras sparar ni ut den som en ny .smg (kontrolldokument Version 2).

4. Använd den nya versionen av kontrolldokumentet för att uppdatera arbetsfilen med

5. Iterera steg 3 & 4 så länge uppdateringar görs på SOLIDWORKS-filen.

6. Vänta om möjligt till slutet med att lägga till detaljvyer med Digger-verktyget, High Resolution- och Technical Illustration workshops. Dessa vyer måste nämligen uppdateras manuellt.

 

Guide för felsökning ifall ett dokument ej uppdateras korrekt

  1. Vid uppdatering av en Composerfil (.smg) med en SOLIDWORKS-fil måste SOLIDWORKS-filen ha samma namn som den fil som användes vid skapandet av Composerfilen. (Detta går att ändra vid behov, antingen genom att döpa om SOLIDWORKS-filen eller Composerfilens så kallade ”root node”).
  2. Det går ej att uppdatera Composerdokumentet med ett dokument som har andra NetGuids* än originalet. *Vid import av en SOLIDWORKS-fil till Composer får alla ingående delar något som kallas ”NetGuids” vilket är ett slags ID för att kunna identifiera de olika beståndsdelarna vid en uppdatering. NetGuids bestäms av trädstrukturen i SOLIDWORKS-filen samt importinställningarna i Composer.
  3. Ifall du uppdaterar med en SOLIDWORKS -sammanställning så måste sammanställningen vara ”fully resolved” alltså ej i ”lightweight-”, ”large assembly-” eller ”large design review-” mode. Inställningar för detta finns i SOLIDWORKS under Tools>Options>System Options>Assemblies. OBS! Ifall man använder SOLIDWORKS Translator (dvs ej har SOLIDWORKS och Composer installerat på samma dator) så kan man med hjälp av en registerändring se till så att dessa alternativ blir inaktiverade vid import till Composer. För hjälp med detta kontakta supporten.
  4. Importinställningarna ska vara identiska vid uppdateringen som de var vid skapandet av Composer-dokumentet. För att se vilka inställningar som använts öppnar vi vår .smg och kikar under File>Properties>Document Poperties.
  5. Ändra inte om i trädstrukturen i SOLIDWORKS (byt ej plats på under-sammanställningar/parter/geometrier). Vid en uppdatering skrivs sammanställningsträdet över av den nya filen och då gäller det att de ingående delarna ligger på samma ställe för att kunna uppdateras.
  6. Slå inte ihop CAD- eller Composerdokument med en Composer-fil du ska uppdatera (Merge into the current document). Sammanslagna filer försvinner i uppdateringsprocessen.
  7. Skapa inte nya relationer (Parent/child) mellan dina ”geometry actors” i Composer.
  8. Skapa ej meta-data i Composerdokumentet om du ska uppdatera med en SOLIDWORKS-fil, de försvinner i uppdateringsprocessen. Lägg i stället till dessa metadata i SW-filen. Om du i stället uppdaterar dokumentet med ett annat Composer-dokument förvinner ej metadata som skapats i Composerfilen. Dock uppdateras inte metadata ifall båda filerna innehåller samma egenskaper.