Importera kretskort från STEP-fil med förenkling

Du kanske behöver placera ett kretskort i er sammanställning men har problem med importen?

Anledningen till många problem beror på att kretskort innehåller många små koppartrådar och en mängd mindre komponenter som tar lång tid att hantera i MCAD miljön i SOLIDWORKS. Lösningen är att importera på exakt rätt sätt och att förenkla kretskortet genom att ta bort all information som inte behövs i sammanställningen.

Det bästa är att den som skapar STEP-filen försöker spara den med “Without copper”, denna inställning finns bland annat i mjukvaran Altium och tar bort alla små ytelement som utgör koppartrådarna i kretskortet.

 

Så här importerar du kretskort på bästa sätt:

I öppningsdialogen eller i menyn för Options > Import justera alternativ för STEP och General:Aktivera ”3D Interconnect” samt bocka ur ”Import Diagnostics” och ”Entity check”.

Öppna .stp-filen. (ca 1-60 minuter) Välj “No/Nej” på både “Feature recognition” och “Import Diagnostics” (ifall de dyker upp).

Välj “Shaded” iHUD-menyn > “Display style”

Gå in i Options > Document Properties fliken > Image Quality

Sätt Shaded och Wireframe till lägsta kvalitet.

Högerklicka i featuremanager och välj ”Dissolve Components” eller ”Break Link” (ca 1-20 minuter)

Spara parten. (ca 1-30 minuter)

Gå till menyn Tools > Defeature… 

Defeature utför förenkling i 5 steg. Välj antingen att behålla högst ca 30 Bodys eller att rensa småkomponenter: (ca 1-10  minuter)

I Defeature ”Step 2”, markera innerytor i alla hål som ska vara kvar (tex för skruvar) och sedan högerpil. Tryck på högerpilen igen i ”Step 3” så att Defeature genomförs: (ca 1-10 minuter)

Markera “Save as a new document” utan “Link to original” och tryck grön bock: (ca 1-20 minuter)

Stäng ursprungsfilen utan att spara.

Nu bör den nya filstorleken vara ca 10 ggr mindre. (Du kan upprepa Defeature en gång till om så behövs.)

Öppna den förenklade filen.

Om kretskortsplattan fortfarande är full av koppartrådar och kretskortet upplevs tungrott (dvs att den inte är exporterad med inställningen ”Without copper” i tex Altium) så kan plattan behöva ersättas helt med en Boss extrude-feature:

     

    1. Klicka på plattans kantlinje och läs av tjockleken på kretskortet (nere till höger i SOLIDWORKS-fönstret).
    2. Starta ”Boss-Extrude” och starta skissen på ett plan vid kretskortsytan (tex Top Plane) så att planet inte har någon koppling till kretskortet, dvs inte “On surface”.
    3. Använd ”Convert entities” för att importera viktiga hål och kretskortets ytterkontur.
    4. Klicka på ”Display/Delete Relations” och radera alla relationer i listan som heter ”OnEdge”.
    5. Extrudera nu Sketchen till tjockleken utan ”Merge result” med den uppmätta tjockleken på kretskortet.
    6. Dölj både ”Boss-Extrude1” och orginalkretskortets platta med ”Hide”.
    7. Visa ”Boss-Extrude1” igen och välj en lämplig färg om så önskas.
    8. Spara som ”Parasolid *.x_t”, stäng filen och importera Parasolid-filen.
    9. Sätt låg ”Image quality” i Options > Document Properties och spara den förenklade parten (som tex …_Simplified eller …_Förenklad).

    Klart!