Uppdatera mallar för part, sammanställning och ritningar till ny årgång

Document Templates och Sheet Formats

Det kan hända att nyskapade SOLIDWORKS-filer krånglar, inte sällan beror detta på att företagsmallarna som används är flera år gamla (Part, Assembly och Drawing). Därför är det klokt att uppdatera sina anpassade mallar varje gång en ny årgång av SOLIDWORKS installeras. Anledningen är att arkitekturen i mallarna förändras för att kunna hantera nya finesser och förbättringar. Det handlar dels om dokumentmallar och underlagsformat.

SOLIDWORKS har standardmallar i sin filstruktur bland annat i:
C:\ProgramData\SOLIDWORKS\SOLIDWORKS 20xx\templates

Egen-anpassade mallar ska sparas utanför SOLIDWORKS mappar, till exempel på C: eller i PDM så att de är gemensamma för alla användare.

Det går utmärkt att uppdatera äldre mallar till den nya SOLIDWORKS årgång som används. Bara man är noggrann eftersom mallar påverkar alla CAD-filer som skapas framöver.
Du kan själv undersöka hur gammal mallen är. I en Part eller Assembly genom att högerklicka på ett plan (tex Front) och välja “Properties”. Läs datumet för “Date created” och “Last modified”.

 

Det går också att i Windows högerklicka på mall-dokumentet och välja “Egenskaper” för att under fliken “Information” läsa datumet för “Skapad den” eller “Senast ändrad”.

Förberedelser

  1. Skapa en ny mapp på tex skrivbordet eller annan lämplig tillfällig plats. Detta blir “Arbetsmappen” där mallar kommer att skapas och testas innan de kan användas i arbetet.
  2. I SOLIDWORKS gå till Options > File locations > Edit All
  3. Kopiera dina filsökvägar för “Document Templates” och “Sheet Formats” som inte är en filsökväg till SOLIDWORKS egna filstruktur. Klistra in sökvägarna till en textfil. Spara textfilen i Arbetsmappen.
  4. Stäng “Edit all”-fönstret utan att ändra något.
  5. Radera alla sökvägar för “Document templates” i “File Locations” med “Delete” knappen.
    Lägg till filsökvägen till Arbetsmappen i “Document templates” med “Add”-knappen.
  6. Tryck på “OK” så att Optionsfönstret stängs (ändringarna sparas).
  7. Tryck på “Ja” två gånger för att skapa sökvägar i Windows.
  8. Tryck File > New för att starta en ny Part och stäng sedan parten utan att spara. Nu har standardmallar för Part, Assembly och Drawing automatiskt genererats i Arbetsmappen.
  9. Nu kan du kopiera och klistra in den tidigare sökvägen från textfilen till “Document templates” igen med “Add”-knappen.
  10. Växla från “Document templates” till “Sheet Formats” och lägg till Arbetsmappen där utöver er filsökväg och tryck “OK” för att stänga Options fönstret.

Skapa de nya mallarna Part-, Assembly- och Drawing

    Spara Drafting Standard och Sheet Formats

Drafting standard innehåller de flesta “Document Properties”-inställningarna från den äldre mallen.

  1. Öppna företagets äldre mall (Part/Assembly/Drawing) genom att antingen:- Peka ut mappen med företagets mallar i Options > File locations igen (finns i textfilen) och skapa en ny Part/Assembly/Drawing med den.- Eller öppna den äldre mall-filen med “Open” med alternativet “Template (*.prtdot, asmdot, drwdot)”.
  2. Öppna nu mallens Options > “Document Properties” och under “Overall Drafting Standard” välj om möjligt “Save to external file…” till Arbetsmappen. Notera annars vilken standard som används i mallen (ISO, ANSI etc.). Spara separata Drafting standars för Part, Assembly och varje Drawing ifall det förekommer olika inställningar i dessa.
  3. För Drawing templates spara också ut “Sheet Format” till Arbetsmappen med File > “Save Sheet Format…” med arkstorlek (tex A1, A2, A3, A4 Landscape och A4 Portrait) och årtal i filnamnet för enklare administration (tex “Underlagsformat A3 2022”).

     Skapa Part/Assemblymallar

  1. Skapa nu ett nytt Part/Assembly/Drawing-dokument med en ny mall (File > New>Arbetsmappen) och öppna Options > Document Properties och välj “Load From External File”. Öppna den sparade *.sldstd-filen för den sortens mall  i Arbetsmappen.
  2. Spara ut en uppdaterad Part/Assembly-mall med Save as “Part/Assembly Template (*.prtdot/asmdot)”. Ett tips är att lägga till årtalet i filnamnet för enklare framtida administration. Stäng sedan Part/Assembly-dokumentet.

    Skapa Ritningsmallar

  3. Alternativ 1 för flera Drawing templates:
    Är det en Drawing och ni vill ha ritramen inbyggd i varje ritningsmall, högerklicka på “Sheet” eller “Sheet Format” och välj Properties och från Arbetsmappenöppna välj ett nytt Sheet Format (*.slddrt) och tryck på “Apply changes”.Spara nu ritningsmallen som Drawing templates (*.slddrt) till Arbetsmappen. Använd ett filnamn på mallen som beskriver arkstorlek och årgång. tex “Underlagsformat A3 2022”.
    Fortsätt att spara ut resterande ritningsmallar genom att växla Sheet Format i tur och ordning i ritningen och spara ut Drawing template för varje Sheet Format.Alternativ 2 för en Drawing template med flera Sheet Formats:
    Om ni bara vill ha en Drawing-mall där man får välja Sheet Format varje gång en ritning skapas, högerklicka på ritningens “Sheet Format” under Sheet och välj Delete och spara som Drawing template (*.slddrt).
    Spara nu den tomma ritningsmallen som Drawing templates (*.slddrt) till Arbetsmappen. Använd ett filnamn på mallen som beskriver arkstorlek och årgång. tex “Underlagsformat A3 2022”.


    Testa mallar

  4. Skapa en ny Part/Assembly/Drawing och testa att alla mallars inställningar stämmer, dvs Drafting standard, Custom properties och att ritramen har rätt storlek i ritning).
    Spara om mallen ifall den behövde rättas.
  5. Repetera samma sak för alla Part/Assembly/Drawing-mallar. Har ni flera ritningsmallar (Drawing Templates, *.drwdot) repetera proceduren för varje ritningsmall.

Använda de nya mallarna

  1. I SOLIDWORKS > Options > File locations > Document Templates
    Lägg till sökvägen som sparats i textdokumentet genom att kopiera och med “Add”-knappen klistra in sökvägen.
    Ta bort sökvägen till Arbetsmappen med “Delete”-knappen.
  2. Öppna ett Utforskaren-fönster och klistra in sökvägen från textdokumentet.
  3. Markera alla dokumentmallar i mappen eller lägg dem i en ny mapp.
  4. Högerklicka och välj “Skicka till” och välj “Komprimerad mapp” så att det skapas en zip-fil.
  5. Radera sedan dokumentmallarna (prtdot, asmdot och drwdot) men behåll zip-filen.
  6. Öppna nu ett nytt Utforskaren-fönster och gå till Arbetsmappen.
  7. Kopiera från arbetsmappen alla nya dokumentmallarna för Part/Assembly/Drawing (*.prtdot, *.asmdot, *.drwdot).
  8. Klistra in dessa i det andra utforskaren-fönstret.
  9. Prova nu att skapa ett nytt dokument i SOLIDWORKS för att se att de nya mallarna syns där.
  10. Gör nu samma sak för Sheet Formats med dess filsökväg som finns i textdokumentet.
  11. Prova att byta Sheet Format i en ritning (Högerklick på Sheet > Properties) och se om de nya underlagsformaten syns i listan.
  12. Nu kan du eventuellt arkivera Arbetsmappen med högerklick, “Skicka till” och välj “Komprimerad mapp” och sedan kasta Arbetsmappen.
  13. Klart!